
What is a nonce error? According to Google:
A “nonce” (number used once) is a security token used to verify that a request to a server is legitimate and intentional. A nonce error means the server’s security check failed, usually because the token expired, was issued to someone else, or was cached incorrectly.
When running a WordPress website, you want to keep it secure so that your forms, content, data, and users are safe from attacks and other malicious activity. One way you can do that is by using “nonces”.
“Nonces” are one-time tokens designed to protect forms and URLs from certain types of misuse, like Cross-Site Request Forgery (CSRF). Basically, a “nonce” is generated for a given user in a given context so that it’s unique to not only the WordPress install and user, but to the action, the object of the action, and the time of the action.
So let’s say a user opens a post to edit in their WordPress dashboard, then decides to delete it. When submitting the request to delete it, WordPress will verify if a previously generated “nonce” expected for this exact WordPress install, user, purpose, post, and time period was sent along. It will then decide if the user’s request can be safely processed. If it can’t, then it will return an error message.
This error mechanism is designed to prevent repeated, expired, malicious, or otherwise unwanted submissions and requests from being processed on your WordPress website — but it can also prevent real users from submitting forms or completing other actions on your site.
I am aware of this problem, It has been an on and off problem for a while. I apologize for any inconvenience this has caused you. This is no minor issue for me to fix, but I plan to dedicate a day or two next week to resolving the problem. I am pretty sure that my theme is the issue, but I won’t know that until I swap out the theme with a new one. I have been using the same theme since 2014. Once the theme is changed, the nonce problem should resolve itself. If not, that means I’ll need to consider caching issues or some other unknown issue as the culprit. WordPress just pushed out a major software upgrade. It is causing several minor conflicts with my theme. Another sign that it is time for me to make a change. One reason I am hesitant is that WordPress has gone to Gutenberg block editing for building themes, a more laborious task, to say the least.
I shall overcome, right after someone backs this truck off my body. 🙂
I appreciate your patience and understanding.

Bruce Gerencser, 69, lives in rural Northwest Ohio with his wife of 48 years. He and his wife have six grown children and thirteen grandchildren. Bruce pastored Evangelical churches for twenty-five years in Ohio, Texas, and Michigan. Bruce left the ministry in 2005, and in 2008 he left Christianity. Bruce is now a humanist and an atheist.
Your comments are welcome and appreciated. All first-time comments are moderated. Please read the commenting rules before commenting.
You can email Bruce via the Contact Form.
Want to Respond to Bruce? Fire Away! If You Are a First Time Commenter, Please Read the Comment Policy Located at the Top of the Page.